Welcome to SynthEdit Q&A, where you can ask questions and receive answers from other members of the community.

Is patch memory for blobs supported ?

0 votes
asked Jun 25, 2010 by robert (140 points)
Starting from an SDK 3 example, I made a gui module that takes user click-and-drag to draw a series of bars in a window, and outputs them as an array of floats to a blob pin.  Since there isn't a built-in patch memory module for blobs, I copied the SDK patch mem example for floats and just changed datatype on the parameter and some pins to make one.  It works fine to store and recall/display user-drawn values in a host. However, when I add a Patch Automator module, patch change is ignored for the blob, so one blob applies to all patches. Should I have been able to get patch change to work with a blob? Thanks,
Robert

1 Answer

0 votes
answered Jun 28, 2010 by Jef (5,310 points)
Yes it should work I think. Just check if 'ignore PC' is off on the automation screen.
commented Jun 29, 2010 by robert (140 points)
I checked the automation settings for patch change, but that didn't resolve it. Here's a link to a small test project http://www.12equalboresme.com/patchmemBlob/BlobTest.zip
commented Jun 30, 2010 by Jef (5,310 points)
HI, You file is compiled with VS2005 Debug version. I'm not able to load it. Please compile a Release version?
commented Jul 1, 2010 by robert (140 points)
Files at the above link have been updated to release builds.  Thanks for your interest!
commented Jul 1, 2010 by Jef (5,310 points)
Your module is transmitting it's state correctly, but not redrawing in response to updates from the patch-mem. If you are able to post the code on the SDK mailing list, I am glad to help...
http://groups.yahoo.com/group/syntheditsdk
commented Jul 1, 2010 by Jef (5,310 points)
Your module is transmitting it's state correctly, but not redrawing in response to updates from the patch-mem. If you are able to post the code on the SDK mailing list, I am glad to help...
http://groups.yahoo.com/group/syntheditsdk
commented Jul 2, 2010 by robert (140 points)
Thanks so much for pointing out where my problem was!! Got it fixed now - blob patch data works great!
...